Critical Remote code execution vulnerability in all ZYXEL firewalls &VPNs. Patch now

Zyxel security teams have confirmed the finding of a critical vulnerability affecting their firewall solutions and VPN access points that would allow threat actors to run remote code on the victim’s system.

Tracked as CVE-2020-25014, this is a buffer overflow failure that can be manipulated through an unknown entry, leading to memory corruption issues that could have a severe impact on the victims’ device.

The vulnerability received an 8.5/10 score according to the Common Vulnerability Scoring System (CVSS) and experts consider it highly easy to exploit, although additional details are unknown.  In his report, Zyxel mentions: “A fbwifi_continue.cgi stack-based buffer overflow on Zyxel UTM and the VPN series of gateways running firmware version V4.30 up to V4.55 allows unauthenticated remote attackers to execute arbitrary code through a designed http packet.”

In addition, all Zyxel products affected by the flaw are compatible with Facebook’s WiFi feature, so developers released patches for all relevant products.

This is not the first time a company offering security services has been patching its own vulnerabilities. Last week, cybersecurity firm Sophos revealed that he was the victim of a data breach that may have compromised confidential information for a small number of clients.

Although the flaw can be exploited by remote threat actors over the Internet, although specialists have not detected exploit attempts in real-world scenarios.

Vulnerabilities have already been fixed, so users in affected deployments are advised to update as soon as possible.

You may also like...